Ask Your Question

I tried to upgrade via $sage -upgrade and got an error

asked 2016-02-22 05:39:23 -0500

nbartkowiak gravatar image

sage prints:

Upgrading to the latest development version fatal: Unable to find remote helper for 'https'

Any idea what to do next? TIA

edit retag flag offensive close merge delete



Could you please give us some informations so that someone can try to reproduce your problem:

  • which version of Sage did you use ?
  • which OS ?
  • did you install Sage from the binaries, and which ones ?
  • did you compile Sage yourself ?
  • which command did you type precisely to get the error ?
  • which error message did you get ?
  • ... ?
tmonteil gravatar imagetmonteil ( 2016-02-22 05:50:05 -0500 )edit

For "what to do next?", you can just back up you ~/.sage and then download a fresh copy of sage binary. I do it all the time, simply because it leaves one with a working copy of sage in case anything goes wrong during the upgrade (though it rarely so).

Eugene gravatar imageEugene ( 2016-02-23 14:16:44 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2016-02-23 08:35:15 -0500

slelievre gravatar image

updated 2016-02-24 05:58:49 -0500

Upgrading from a pre-7.0 version of SageMath to a post-7.0 version is not supported. Instead, install the new version.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-02-22 05:39:23 -0500

Seen: 98 times

Last updated: Feb 24 '16