Ask Your Question
1

Rewriting paths gives OSError before launching Sage

asked 2016-01-31 15:12:27 -0500

done_with_fish gravatar image

updated 2016-07-05 15:04:40 -0500

FrédéricC gravatar image

Running sage in my terminal gives the following output

Rewriting paths for your new installation directory
===================================================

This might take a few minutes but only has to be done once.

patching /usr/lib/sagemath/src/build/cythonized/sage/structure/list_clone.c
Traceback (most recent call last):
  File "/usr/lib/sagemath/relocate-once.py", line 85, in <module>
    p('src/build/cythonized/sage/structure/list_clone.c').substitute().save()
  File "/usr/lib/sagemath/relocate-once.py", line 70, in __call__
    return FilePatch(self, filename)
  File "/usr/lib/sagemath/relocate-once.py", line 21, in __init__
    self.st = os.stat(filename)
OSError: [Errno 2] No such file or directory: '/usr/lib/sagemath/src/build/cythonized/sage/structure/list_clone.c'
┌────────────────────────────────────────────────────────────────────┐
│ SageMath Version 6.10, Release Date: 2015-12-18                    │
│ Type "notebook()" for the browser-based notebook interface.        │
│ Type "help()" for help.                                            │
└────────────────────────────────────────────────────────────────────┘
sage:

I'm curious how I can fix this error.

edit retag flag offensive close merge delete

Comments

Wow, that is new to me. Can you give us more details about your platform and your binary (I assume you downloaded a binary or these errors might not appear)?

kcrisman gravatar imagekcrisman ( 2016-02-01 21:20:05 -0500 )edit

I'm running Ubuntu 14.04 and installed sage with the Ubuntu PPA with the commands found here: http://www.sagemath.org/download-linu...

done_with_fish gravatar imagedone_with_fish ( 2016-02-01 21:48:20 -0500 )edit

1 answer

Sort by » oldest newest most voted
2

answered 2016-02-03 00:54:04 -0500

pipedream0 gravatar image

Hi

This error message is specific to the PPA. At the moment we have not traced further errors caused by this and have held off on reverting to 6.9.

The relocate-once.py introduced recently is not compatible with how we have been using debian package building, but we are investigating fixes for this.

Please post any other error which might be a result of this message.

Regards, Jan

edit flag offensive delete link more

Comments

Hi

Please update to sagemath-upstream-binary-full 7.0 to fix this.

The smaller version, sagemath-upstream-binary, will be fixed at the latest by 7.1, but maybe sooner.

Regards, Jan

pipedream0 gravatar imagepipedream0 ( 2016-02-04 00:59:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-31 15:12:27 -0500

Seen: 465 times

Last updated: Feb 03 '16