Ask Your Question
2

Installing optional package

asked 2015-11-24 10:40:58 -0600

Malte gravatar image

I am running Sage 6.9 (notebook) on a Windows 10 machine via VirtualBox (Oracle VM VirtualBox Version 5.0.10 r104061, GUI-based).

For some purpose I need the "database_gap" extension package which has to be installed separately. This, however, is a huge problem to me. I tried to implement every piece of advice I could find in this forum or elsewhere on the internet. First, I typed install_package(package="database_gap") into the notebook and was told to use the shell prompt instead (Run 'sage -i database_gap' from a shell prompt instead). I then used the Windows command line to access the folder of virtualbox (C:/program files/Oracle/virtualbox) and typed in just that. Syntax error ("Command doesn't exist"). I then tried several variations, e.g. I put in the word VBoxManage at the beginning of the command, replaced Sage by Sage-6.9 and database_gap by database_gap-4.7.8 (which is the actual name of the package folder which I downloaded). Nothing worked.

Surely a sophisticated piece of software such as Sage will offer a more obvious and user-friendly way to install optional packages. But what exactly must I do? I seek your advice and kindly ask for some sort of help that can be understood even by those who are not computer experts (like me).

Thanks, Malte

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-11-25 07:21:53 -0600

tmonteil gravatar image

You should run the sage -i database_gap command from a Linux terminal within VirtualBox. You can get one such terminal by clicking on Ctrl + F1from the VirtualBox desktop, see http://wiki.sagemath.org/SageApplianc...

edit flag offensive delete link more
1

answered 2015-11-24 11:21:06 -0600

You should use the command line of the linux in the virtual box. Windows does not know anything about what is inside the virtual machine.

edit flag offensive delete link more
0

answered 2015-11-25 08:45:43 -0600

Malte gravatar image

Thank you very much, both of you. It works now. Usually I am not quite as stupid as I am probably appearing now, but yesterday I really could not find the command terminal within VirtualBox. Maybe there was some confusion in the configuration of the keyboard within the the virtual machine, because I could swear Ctrl + F1 did not start the terminal then. But today it does. As I couldn't start that the terminal yesterday I slowly came to the (wrong) conclusion that it doesn't exist, which is why I resorted to the Windows command line instead.

Thank you very much indeed.

Malte

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-24 10:40:58 -0600

Seen: 368 times

Last updated: Nov 25 '15