Ask Your Question
1

libgd error when upgrading SageMath in Ubuntu 14.04

asked 2015-10-29 07:40:54 -0500

kksinfinity gravatar image

updated 2015-10-29 10:28:16 -0500

I get the error reported at http://trac.sagemath.org/ticket/18293 while upgrading SageMath in Ubuntu-14.04. I am forced to go back to version 6.2 as upgrading from 6.8, 6.7, 6.4 ended up with the libgd-2.1.1.p0 error and no usable Sage.

I am unable to find resolution of the http://trac.sagemath.org/ticket/18293 error in the repositories. What is the present status of upgrading Sage in this context?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-10-29 17:20:29 -0500

fidbc gravatar image

Here you can find a patch that helped me solve a similar build problem on Arch. I'm guessing it is the same issue as in ticket 18293 since libvpx is involved.

Are you building sage from source?

edit flag offensive delete link more
0

answered 2015-10-29 14:35:13 -0500

kcrisman gravatar image

Well, it is there, anyway:

$ git log build/pkgs/libgd/
<stuff>    
commit fd489bf083f69e84c48ead6b6b7afa521593d783
Author: <snip>
Date:   Fri Apr 24 13:19:10 2015 +0200

    update libgd to 2.1.1

commit 7dcb52394e0465210352ecc4c614d9b8130a58a1
Author: <snip>
Date:   Fri Apr 24 13:18:35 2015 +0200

    add patch to libgd to fix build error

But I can't answer as to whether that should have fixed your specific error. Maybe that only worked on Arch and is unrelated to this, or maybe it's a different libpvx issue?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-10-29 07:40:54 -0500

Seen: 57 times

Last updated: Oct 29 '15