Ask Your Question
1

Sage 6.7 unusable on high res display

asked 2015-06-17 12:13:35 -0500

Cedric_N gravatar image

Installed Sage 6.7 on a new Windows 8.1 Notebook with a 3200x1536 pixel display. All works fine, but Sage is unusable because the fonts are way too small. It seem that VirtualBox is hardwired to assume 72dpi displays and scales accordingly. Is there a way to override this?

During the boot sequence, a CentOS screen is shown briefly. Is there a way to get into the guest OS to edit the X11 config files in /etc/X11/... ? I don't really want to go there, but I could not find any way to fix this so far.

I'm sorry for the mundane nature of this question, but it is a show-stopper for me.

Kind regards, -- Andreas

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-06-22 13:29:21 -0500

nbruin gravatar image

updated 2015-06-22 13:34:52 -0500

Possibly an easier way of getting this to work that doesn't depend telling a virtual machine it will be displaying graphical output on a HiDPI device would be to get the virtual machine to accept connections on a network interface that can be connected to from the host machine and then connect with a browser on the Windows side with the sage server/worker in the virtual machine. That way the graphics on the virtual machine side are completely irrelevant.

According to http://wiki.sagemath.org/SageAppliance you should be able to connect to https://localhost:8000 on the windows side and get a connection to the sage notebook running in the virtual machine. The "virtual machine" window should be basically irrelevant from that point onward.

I have tried to deal with similar issues and I don't think just changing the DPI value to 200 will work -- modern linux distributions seem to work nicely on HiDPI (and they seem to detect when to do so), it seems they tend to arrive there by working around X11's idea of DPI (for instance, for gnome the magic seems to be gsettings set org.gnome.desktop.interface scaling-factor 2), and for some legacy applications I haven't found a way to fix them (certainly, anything depending on bitmap fonts seems out of luck). For instance, for maple's graphical interface I have found the accessibility "Desktop Zoom" the only reasonable option (Super+Alt 8 in Gnome -- if you set the mouse to "push" rather than "center" it's actually pretty usable).

edit flag offensive delete link more
0

answered 2015-06-18 09:36:13 -0500

tmonteil gravatar image

You can get into the guest shell by pressing Right-Ctrl + F1, then you should be able to edit the files in /etc/X11/, see http://wiki.sagemath.org/SageApplianc...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-06-17 12:13:35 -0500

Seen: 351 times

Last updated: Jun 22 '15