Ask Your Question
0

How use Maxima on iPad app?

asked 2015-05-27 13:20:09 -0600

rb57cat gravatar image

updated 2015-05-27 16:08:46 -0600

kcrisman gravatar image

Hi, I am using the Sage app on my iPad and I would like to reuse some maxima scripts.

When I try:

default_mode(maxima) 
fpprec 
ss: 44 
ss-2

I get:

  File "<ipython-input-1-156fa75fa7d5>", line 4 
    ss: Integer(44) 
      ^ 
SyntaxError: invalid syntax

Can anyone help please?

Regards, Rob.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-05-29 17:14:56 -0600

rb57cat gravatar image

By chance I have just re-read the sage info bundled with the app.

It says there the language can be selected by a long tap on the 'sage' button in the cell, or in the app settings.

This did not register with me when I first read it!

Apologies for wasting people's time,

Regards, Rob.

edit flag offensive delete link more
0

answered 2015-05-27 16:09:45 -0600

kcrisman gravatar image

I don't have access to it, but I suspect you can't use it like that. Can you choose %maxima? Otherwise you may have to tediously do maxima(...) each time.

edit flag offensive delete link more

Comments

Apologies if this is not the correct way to respond, I am unfamiliar with this forum style.

Thanks, your suggestion did not work but it did lead me to the discussiion 'other modes for sage cell server' where I found this method: maxima.eval(r""" fpprec ss: 44; ss-33; ss+ss; """) This works except that 'newline' is replaces by '/n' Is there any parameter relating to newline?.

Thanks again, Rob.

rb57cat gravatar imagerb57cat ( 2015-05-28 05:45:37 -0600 )edit

You can actually edit your question, that's probably the easiest way. As to newlines, that is true it would happen. But you should be able to do multiple lines and they would all evaluate, though perhaps only the last one would print.

kcrisman gravatar imagekcrisman ( 2015-05-28 12:45:38 -0600 )edit

Thanks, the I/p was multi-line but it got compressed in the post. I should have made it clear I meant that the output had the '\n's instead of new lines. Not really a show stopper! Regards, Rob.

rb57cat gravatar imagerb57cat ( 2015-05-28 13:28:44 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-27 13:20:09 -0600

Seen: 623 times

Last updated: May 29 '15