Ask Your Question

Jmol applet in Sage 6.3 cannot load

asked 2015-01-02 06:56:49 +0200

ikol gravatar image

updated 2015-01-02 13:59:10 +0200

slelievre gravatar image


I am going trough the Tutorial using Notebook. Under 3D plotting, I am trying to run the first example. The static 3D plot is generated but when I click "Make it Interactive", the Jmol applet fails to load. The error message says JmolApplet#0 has trouble loading, will try again. However, it fails loading. This is the Sage screen output I get:

java version "1.7.0_65"
OpenJDK Runtime Environment (IcedTea 2.5.3) (7u71-2.5.3-0ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
This application does not specify a Codebase in its manifest. Please verify with the applet's vendor. Continuing. See: for details.
Application title was not found in manifest. Check with application vendor
Application title was not found in manifest. Check with application vendor
script ERROR: script ERROR: io error reading http://localhost:8080/home/_sage_/30/cells/14/cells/14/|SCRIPT: http://localhost:8080/home/_sage_/30/cells/14/cells/14/

I have Open JDK 7 and IcedTea installed on Ubuntu 14.04 (64-bit). If I go to the Jmol website, I can run their demo and the Jmol applet IcedTea loads just fine in Firefox, it only doesn't work in the Sage Notebook.

Thanks for your help,


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-01-02 14:26:36 +0200

how about the latest stable version of Sage, 6.4.1?

edit flag offensive delete link more


Thanks, Dima for your comment. Version 6.4.1 works fine with Jmol.

ikol gravatar imageikol ( 2015-01-03 18:56:35 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2015-01-02 06:56:49 +0200

Seen: 856 times

Last updated: Jan 03 '15