Ask Your Question
0

PowmInsecureWarning, how do I rebuild using libgmp >= 5

asked 2014-12-09 14:45:38 -0500

Mike 451 gravatar image

1st Awesome work !! thank you very much !! Quite a task getting all that external code working together.

Successfully built 6.4.1 on an 8GB iMac with no problems in 3 hour 6 minutes. I forgot to use the multiprocessor setting.

Only issue is when starting notebook() I get this warning: /sage-6.4.1/local/lib/python2.7/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec. You should rebuild using libgmp >= 5 to avoid timing attack vulnerability. _warn("Not using mpz_powm_sec. You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)

How do I update this.

thanks

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-12-09 19:44:45 -0500

kcrisman gravatar image

This is not actually a bug. We use a replacement for GMP called MPIR. You don't have to worry about this warning. See e.g https://groups.google.com/forum/#!top...

edit flag offensive delete link more

Comments

thanks again

Mike 451 gravatar imageMike 451 ( 2014-12-09 23:22:45 -0500 )edit

Great - just let us know if you have more questions!

kcrisman gravatar imagekcrisman ( 2014-12-10 07:55:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-12-09 14:45:38 -0500

Seen: 1,988 times

Last updated: Dec 09 '14