Ask Your Question
1

sageserver dose not evaulate

asked 2014-11-12 16:37:54 -0600

boy007+1 gravatar image

updated 2014-11-13 10:16:16 -0600

commandline sage works but at browser I do not get results after pressing evaluate.

Ubuntu 14.04 LTS upgrade done from12.04 LTS as well sage to 6.3

Executing /etc/init.d/sageserverD start ..

Removing stale pidfile sage_notebook.sagenb/sagenb.pid
/home/sageserver/sage-6.3/local/lib/python2.7/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.
  _warn("Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)
/usr/bin/xdg-open: 461: /usr/bin/xdg-open: links2: not found
/usr/bin/xdg-open: 461: /usr/bin/xdg-open: links: not found
/usr/bin/xdg-open: 461: /usr/bin/xdg-open: lynx: not found

==========================

This comes from tests

----------------------------------------------------------------------
sage -t src/sage/dev/trac_interface.py  # 129 doctests failed
sage -t src/sage/dev/git_interface.py  # 204 doctests failed
sage -t src/sage/dev/user_interface.py  # 25 doctests failed
sage -t src/sage/dev/patch.py  # 78 doctests failed
sage -t src/sage/dev/sagedev_instance.py  # 2 doctests failed
sage -t src/sage/dev/sagedev_wrapper.py  # 20 doctests failed
sage -t src/sage/dev/cmd_line_interface.py  # 24 doctests failed
sage -t src/sage/dev/config.py  # 52 doctests failed
sage -t src/sage/dev/sagedev.py  # 748 doctests failed
sage -t src/sage/dev/test/trac_interface.py  # 15 doctests failed
sage -t src/sage/dev/test/user_interface.py  # 15 doctests failed
sage -t src/sage/dev/test/config.py  # 3 doctests failed
sage -t src/sage/dev/test/server_proxy.py  # 61 doctests failed
sage -t src/sage/dev/test/trac_server.py  # 2 doctests failed
sage -t src/sage/dev/test/sagedev.py  # 11 doctests failed
sage -t src/sage/doctest/control.py  # 1 doctest failed
----------------------------------------------------------------------
Total time for all tests: 4616.7 seconds


============

sageserver@mpi1:~/sage$ cat ../buildSAGE
export SAGE64=yes
export SAGE_KEEP_BUILT_SPKGS=yes
MAKE='make -j7'
sage -i pyopenssl #-i
sage -i openssl
sage -f python
SAGE_UPGRADING=yes make ssl
make ssl
sageserver@mpi1:~/s

====

sageserver@mpi1:~$ cat start*
#!/bin/sh

/home/sageserver/sage/sage -c "notebook(interface='localhost',
directory='./sage_notebook.sagenb',
automatic_login=true,
secure=false,
port=9999,
accounts=true,
timeout=3600,
server_pool=['sage%d@localhost'%i for i in range(2)],
ulimit='-u 100 -t 36000 -v 500000')"
 #!/bin/sh

~sage/sage -c "not
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-11-15 12:29:20 -0600

boy007+1 gravatar image

This error was caused: 1) some libraryes did not upgraded due disconneting 4G network from Elisa 2) there was also wrong file rights 3) sage0 - sage9 user group wrong

joni

edit flag offensive delete link more
1

answered 2014-11-12 17:41:53 -0600

updated 2014-11-12 17:43:33 -0600

Hello,

Comes from a misconfiguration of your xdg settings... depending on your preferred browser do

xdg-settings set default-web-browser firefox.desktop

or

xdg-settings set default-web-browser google-chrome.desktop

See also this thread on sage-release

Vincent

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-11-12 16:37:54 -0600

Seen: 111 times

Last updated: Nov 15 '14