Ask Your Question
0

Trouble Installing Plotly on a Sage VirtualBox

asked 2014-03-27 06:09:40 -0600

russ_hensel gravatar image

Trouble Installing Plotly on a Sage VirtualBox

I am trying to use plotly on a virtual box vm using the downloaded virtual machine image of SageMath.

I can get to the command line, <right-ctrl and="" f1="">

I did not have pip which is used to install plotly but got it with

"sudo yum -y install python-pip"

then ran pip to get plotly

"sudo /usr/bin/pip-python ///install plotly"

back in sage <right-ctrl and="" f2="">

"import plotly"

fails

but at the linux command line

"python"

"import plotly"

works, so possibly I installed to the wrong copy of python?

from http://ask.sagemath.org/question/3481... also tried some variaions on "sage --python /usr/bin/pip-python install" all of which failed

any help?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-03-28 05:29:30 -0600

russ_hensel gravatar image

following a suggestion at: http://ask.sagemath.org/question/1382...

it seemed that ./sage --python -m easy_install <package_name>

might work at the command line. plotly was in the python index so I tried

./sage --python -m easy_install plotly

which threw an error, perhaps because of my current directory, but

sage --python -m easy_install plotly

seemed to work, and after a restart of the virtual machine ( which might really be the key to success ) plotly did work in the notebook.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-27 06:09:40 -0600

Seen: 398 times

Last updated: Mar 28 '14