Ask Your Question

Can't change user name.

asked 2013-11-05 00:10:38 +0100

Jim gravatar image

updated 2013-11-05 00:12:14 +0100

How can I change the user name? I have rest the password which I'd forgotten,but don't know how to create a new user name and the notebook won't accept what I thought had been my user name.

edit retag flag offensive close merge delete


What service are you using? Your own local copy of Sage and the sage notebook?

William Stein gravatar imageWilliam Stein ( 2013-11-05 01:06:46 +0100 )edit

The first, I think. Been using it all along, downloaded new version of sage and am now messed up completely. Am almost completely ignorant about IT.

Jim gravatar imageJim ( 2013-11-05 01:25:47 +0100 )edit

1 Answer

Sort by ┬╗ oldest newest most voted

answered 2013-11-05 00:20:34 +0100

Shashank gravatar image

The default username is "admin". You may have been trying username you usually use elsewhere and getting an error because of that. When you reset notebook admin user remains as the default user and the password is reset. However, if you want to create a new user regardless use the following commands at the terminal

from sagenb.notebook.notebook import load_notebook
nb = load_notebook("directory_to_run_sage_in")
user_manager = nb.user_manager()
user_manager.add_user("username", "password", "email@place", "user")
edit flag offensive delete link more


Thank you, but it's all Greek to me. I think I did have a user name for the notebook but can't think of it. Both it and the password were 'saved' and in the past I just hit the button.

Jim gravatar imageJim ( 2013-11-05 01:29:19 +0100 )edit

If you want to know your username just open the terminal and type cd ~/.sage/sage_notebook.sagenb/home and type ls. You will see the usernames of all the users. But if you have reset the notebook you should be able to log in with admin as the username.

Shashank gravatar imageShashank ( 2013-11-05 01:55:34 +0100 )edit

Followed instructions on first command(3x) to get user name - got error messages. Reset password again. Put 'admin' as user name - notebook response 'wrong password'

Jim gravatar imageJim ( 2013-11-05 10:49:17 +0100 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-11-05 00:10:38 +0100

Seen: 1,156 times

Last updated: Nov 05 '13