Ask Your Question
0

[SOLVED] installation from source on debian (kali)

asked 2013-10-23 01:27:32 -0500

Nikkolasg gravatar image

updated 2013-10-23 03:14:16 -0500

Hello everyone,

I've just installed my new OS :

Linux kali 3.7-trunk-amd64 #1 SMP Debian 3.7.2-0+kali8 x86_64 GNU/Linux

But I got this errror when i do make inside the directory.

cd spkg && \
"../spkg/pipestatus" \
    "env SAGE_PARALLEL_SPKG_BUILD='' ./install all 2>&1" \
    "tee -a ../logs/install.log"
/bin/sh: 2: ../spkg/pipestatus: Permission denied
make: *** [build] Error 126

It just makes no sense for me ... :s I've hesitated to post this on the google discussion , tell me if it is the wrong place. Do not hesitate to tell me anything you would need, logs etc ... Thank you

Nicolas

EDIT : I extracted the source in a mounted disk ( sdb1, called Data ) and i copied the unzipped files into my main disk , where the file system is . (into /home/nico )

SOLVED : Effectively, the fact i extracted on another drive was the mistake. At first, i tried to chmod +x pipestatus and there was another error so it lead me to this. Finally, i re dezipped directly on the main disk on my file system, and it is running normally. It is still unclear why that did not work before, because the disk where i unzipped had no "noexec" option but anyway ..

Thank you very much all !!!

edit retag flag offensive close merge delete

Comments

Could you put more details on what you did ? Especially where did you put the files ?

vdelecroix gravatar imagevdelecroix ( 2013-10-23 02:01:42 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-10-23 01:47:47 -0500

tmonteil gravatar image

updated 2013-10-23 01:53:41 -0500

It seems that you unpacked the source tarball in a directory on which a device is mounted with a noexec option. This may be the case if you did it on /tmp/ which is likely to be a tmpfs on RAM.

To understand this, go into the sage source directory, and type

df .
mount

(do not forget the dot in the first command), here you see which device is mounted on the directory, and then you can see whether there is a noexec option to the corresponding mount line.

If this is the case, just put the sage directory on a "regular" filesystem (typically: a POSIX filesystem on a hard disk).

edit flag offensive delete link more
0

answered 2013-10-23 02:37:41 -0500

Nikkolasg gravatar image

updated 2013-10-23 03:04:09 -0500

Thanks for your fast reply !

here is the output :

root@kali:/home/nico/sage-5.12# df .
Filesystem                                             1K-blocks     Used Available Use% Mounted on
/dev/disk/by-uuid/f24ed693-917a-493b-a837-5fd40e066b1a  64008052 11062768  49693780  19% /
root@kali:/home/nico/sage-5.12# mount
 ...
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=789244k,mode=755)
/dev/disk/by-uuid/f24ed693-917a-493b-a837-5fd40e066b1a on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
...
/dev/sdb1 on /media/Data type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)

Actually you are right about the fact that i did unzipped the sage tar ball in a mounted disk (sdb1 ) , but after i copied it into my main disk (/dev/disk/by-uudid/f24.....) where the filesystem is, and it doesn't show any noexec options .

Got any others ideas ?

Ps : I've looked into the spkg, and Makefile, and i don't understand why would you use a special pipe script that uses the normal one ..?

edit flag offensive delete link more

Comments

If you are happy you can close the question by selecting the tmonteil answer as the good one (there is a button on the left). And enjoy Sage!

vdelecroix gravatar imagevdelecroix ( 2013-10-23 05:33:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-10-23 01:27:32 -0500

Seen: 626 times

Last updated: Oct 23 '13