Ask Your Question

unicode in sage terminal

asked 2013-04-26 12:02:58 +0200

Moataz Elmasry gravatar image

updated 2013-04-26 13:16:31 +0200

fidbc gravatar image


when I type

sage: "ä"
'\xc3\xa4' #latin1
sage: u"ä"
u'\xe4' #utf-8

I was actually hoping to display the actual character ä. I'm aware of issues #13296 and patch 1176c4b I have sage 5.8 installed through ubuntu 12.04 repository Still though I can't seem to print a german umlaut 'ä' neither in a sage terminal nor in a notebook

Anyone has the same problem in sage 5.8?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2013-04-26 13:19:44 +0200

fidbc gravatar image

updated 2013-04-26 13:53:20 +0200

kcrisman gravatar image

Here is a related question in stackoverflow.

This seems to work for me

sage: print u"ä".encode('utf-8')
edit flag offensive delete link more



[This SO question]( specifically addresses the Ipython issue - or, rather, that Ipython has issues.

kcrisman gravatar imagekcrisman ( 2013-04-26 13:53:57 +0200 )edit

thnx it works great!!

Moataz Elmasry gravatar imageMoataz Elmasry ( 2013-04-28 10:30:07 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-04-26 12:02:58 +0200

Seen: 1,461 times

Last updated: Apr 26 '13