Ask Your Question

[solved] no way to install zeromq under sage 5.8

asked 2013-04-23 11:09:18 +0100

undy gravatar image

updated 2013-04-23 12:27:19 +0100

Hi there,

I have been trying for days to install zeromq under fresh installations of Sage 5.8 on two different machines, one with Ubuntu 12.04.2 (32-bit), and the other with Ubuntu 12.10 (64-bit). I tried to install zeromq by means of:

./sage -i zeromq

as well as installing "sagemath-optional" from the repository. In all cases, the installation fails apparently because of this:


checking alloca.h usability... no

checking alloca.h presence... yes

configure: WARNING: alloca.h: present but cannot be compiled

configure: WARNING: alloca.h: check for missing prerequisite headers?

configure: WARNING: alloca.h: see the Autoconf documentation

configure: WARNING: alloca.h: section "Present But Cannot Be Compiled"

configure: WARNING: alloca.h: proceeding with the compiler's result


(The full log is here.)

What's wrong? Can anybody help me?

Thanks, Andrea

PS. On one of the two machines, I also compiled gcc 4.7.2 (sage -f gcc) but it did not help at all.

edit retag flag offensive close merge delete


I can confirm it *does* install properly on OS X 10.7 and on sage.math (which is Ubuntu 8.04 Hardy Heron) so at least it's not broken everywhere. Can you install other optional packages?

kcrisman gravatar imagekcrisman ( 2013-04-23 11:40:02 +0100 )edit

I don't know whether this may help, could you install the following packages: - `build-essential` - `binutils` - `uuid-dev` - `libtool` - `autoconf` - `automake` and try again ?

tmonteil gravatar imagetmonteil ( 2013-04-23 11:41:25 +0100 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-04-23 12:26:31 +0100

undy gravatar image

updated 2013-04-23 12:27:35 +0100

Thanks for the replies!

Actually, the above-mentioned packages were all installed... but I finally made it!

Here is the procedure I used, in case anyone else had the same problem:

1) I just manually entered the directory:

cd /usr/lib/sagemath/spkg/build/zeromq-2.2.0.p0

2) I started the sage shell:

sage -sh

3) I manually installed the package:

sudo ./spkg-install

In this way, everything goes smoothly. Of course, I still don't know why the automatic installation fails (also the installation of "sage-optional" from the repository fails!), but at least I did it.

Thanks, Andrea

edit flag offensive delete link more


It would really be worth someone tracking this down. Very odd, as your steps 1,2,3 should be exactly what Sage does, in essence.

kcrisman gravatar imagekcrisman ( 2013-04-23 16:03:04 +0100 )edit

Same ubuntu, same sage version, same problem, same solution. Thanks for sharing!

Christian Stump gravatar imageChristian Stump ( 2013-04-26 05:25:22 +0100 )edit

I would actually still like to see this problem solved since I installing this package is part of the sagecell package installation (and I cannot use the detour described above in that case).

Christian Stump gravatar imageChristian Stump ( 2013-04-26 05:38:36 +0100 )edit

Christian: well, if you aren't afraid to modify the sagecell package, you can open it up and comment out the line that installs zeromq in the spkg-install file. Then it will assume that you have zeromq already installed.

Jason Grout gravatar imageJason Grout ( 2013-04-26 14:27:52 +0100 )edit

answered 2013-05-02 08:34:35 +0100

Volker Braun gravatar image

updated 2013-05-02 08:38:22 +0100

I made a new spkg for the current zeromq, our spkg has been a bit outdated. Presumably this will fix your bug. Can you try and post your results to Trac ticket #14518

Upon closer look at your output, how did you install Sage in /usr/lib? Is that the Ubuntu PPA? Of course running install_package as a user does not have the necessary permissions to install anything into root-owned directories.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-04-23 11:09:18 +0100

Seen: 538 times

Last updated: May 02 '13