calling maple

asked 2013-04-16 10:56:31 -0500

k1 gravatar image

I am trying to get maple to work inside sage. I have maple installed and in .bashrc I made an alias to run ./maple from where it is installed when I type 'maple' in terminal, and it works fine:

~$ maple

|\^/| Maple 16 (X86 64 LINUX)

._|\| |/|_. Copyright (c) Maplesoft, a division of Waterloo Maple Inc. 2012

\ MAPLE / All rights reserved. Maple is a trademark of

<____ ____> Waterloo Maple Inc.

 |       Type ? for help.


But when I run a maple command inside sage, for example

sage: maple('2+2')

it returns a TypeError and tells me that I should install maple. I read the documentation here and it says I should have a script called maple and put it in PATH in order to be able to run maple in sage. What I don't understand is where is the PATH. I tried the sage_root (sage installation folder), and home folder. None seem to be working.

Has anyone got this to work, and how?

edit retag flag offensive close merge delete



Sadly, this does appear to be broken. It looks as if there is a fairly recent fix at as well as another one at . Sometimes it seems to depend on the Maple version; Maple 16 is very recent, of course, which looks like part of the issue at those tickets.

kcrisman gravatar imagekcrisman ( 2013-04-16 11:23:26 -0500 )edit

Thanks, shall I report this issue?

k1 gravatar imagek1 ( 2013-04-16 15:58:49 -0500 )edit

I'd see whether the fix at #12295 works, though it does seem that your error is different.

kcrisman gravatar imagekcrisman ( 2013-04-17 02:57:38 -0500 )edit

As to path, type `sage -sh` to get a Sage environment, and then do `echo $PATH` to see what the path Sage sees is.

kcrisman gravatar imagekcrisman ( 2013-04-17 02:58:00 -0500 )edit

Here is the output: "bash: /home/k1/sage5.8/spkg/bin:/home/k1/sage5.8/local/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/k1/.rvm/bin: No such file or directory" But it doesn't mean much to me!

k1 gravatar imagek1 ( 2013-04-17 12:38:31 -0500 )edit