Ask Your Question
1

Add R package in Sage folder

asked 2012-04-10 19:47:52 -0500

mcm3 gravatar image

updated 2012-04-11 09:08:57 -0500

Hi,

Simple question (I think) but have not found anything. I want to add package in R like GGPLOT2 and use it in IDE/command line for sage (not note book). I am using Ubuntu Lucid and have r working on its own.

So.

  1. Is it better to use the R in the Sage folder and add packages to that folder? If so how, as in Ubuntu everything goes to the main R installation.

  2. Or is there an easy way to just point RPy to the main R installation when using SAGE.

edit retag flag offensive close delete

3 answers

Sort by » oldest newest most voted
1

answered 2012-04-11 08:01:27 -0500

kcrisman gravatar image

updated 2012-04-11 08:01:51 -0500

Or you could do

$ sage -R
<snip lots of stuff>
> install.packages('orloca')

and you will probably get some popup or some menu about choosing a CRAN mirror.

edit flag offensive delete publish link more

Comments

This almost works but has not installed anything correctly yet. I have tried orloca, ggplot2, and maptools so far. I will put a big list of output below just FYI. Systems info: Sage 4.7, ubuntu lucid. Other aspects of SAGE are working fine for me.

mcm3 ( 2012-04-11 09:53:28 -0500 )edit

This is some output FYI. matthew@matthew-laptop:~$ sage -R Error in if (file.info(codeFile)["size"] == file.info(loaderFile)["size"]) warning("package seems to be using lazy loading already") else { : missing value where TRUE/FALSE needed ERROR: lazy loading failed for package ‘proto’ * removing ‘/opt/sage-4.8-linux-32bit-ubuntu_10.04_lts-i686-Linux/local/lib/R/library/proto’ ERROR: dependency ‘plyr’ is not available for package ‘stringr’ * removing ‘/opt/sage-4.8-linux-32bit-ubuntu_10.04_lts-i686-Linux/local/lib/R/library/stringr’ ERROR: dependency ‘colorspace’ is not available for package ‘munsell’ * removing ‘/opt/sage-4.8-linux-32bit-ubuntu_10.04_lts-i686-Linux/local/lib/R/library/munsell’ ERROR: dependency ‘digest’ is not available for package ‘memoise’ * removing ‘/opt/sage-4.8-li

mcm3 ( 2012-04-11 09:55:07 -0500 )edit

for maptools error looks like thismake: /home/wstein/build/sage-4.8/local/lib/R/share/make/shlib.mk: No such file or directory make: * No rule to make target `/home/wstein/build/sage-4.8/local/lib/R/share/make/shlib.mk'. Stop. ERROR: compilation failed for package ‘sp’ * removing ‘/opt/sage-4.8-linux-32bit-ubuntu_10.04_lts-i686-Linux/local/lib/R/library/sp’ ERROR: dependency ‘sp’ is not available for package ‘maptools’ * removing ‘/opt/sage-4.8-linux-32bit-ubuntu_10.04_lts-i686-Linux/local/lib/R/library/maptools’

The downloaded packages are in ‘/tmp/RtmpzrpYpN/downloaded_packages’ Warning messages: 1: In install.packages("maptools") : installation of package ‘sp’ had non-zero exit status 2: In install.packages("maptools") : installation of package ‘maptools’ had non-zero exit stat

mcm3 ( 2012-04-11 09:57:37 -0500 )edit

Hmm, that is puzzling. What happens if you use the "within Sage" option? I think that at least part of the problem is that there are some "hardcoded" parts - see the wstein bits, that shouldn't be there. If it persists, I would try doing sage -f r, assuming you have the right dependencies like fortran on your system, and then doing all of this again.

kcrisman ( 2012-04-11 15:53:57 -0500 )edit

Or you could just build Sage from scratch :)

kcrisman ( 2012-04-11 15:54:06 -0500 )edit
1

answered 2012-04-11 07:15:26 -0500

kcrisman gravatar image

Not sure why Niles thinks you need to do this... this was built in early on by the Sage-R interface.

sage: r.install_packages('ggplot2')

I've even done this live in talks I've given. Naturally, make sure you have an internet connection and that the package you want is supported by the version of R in Sage.

edit flag offensive delete publish link more

Comments

1

Ha! Because Niles isn't really familiar with R -- sorry for the confusion.

niles ( 2012-04-11 07:38:38 -0500 )edit
1

answered 2012-04-11 03:15:34 -0500

niles gravatar image

updated 2012-04-11 07:39:11 -0500

You could switch to a shell with the same environment variable settings that Sage uses. sage -sh starts such a shell for you, and then package installation might work on sage's copy of R instead of the system copy. More details are described for a similar question here:

http://ask.sagemath.org/question/1252/using-psycopg2-and-other-libraries-in-sage

edit flag offensive delete publish link more

Comments

This definitely should work. I'm putting yet another way of thinking of this below.

kcrisman ( 2012-04-11 08:00:02 -0500 )edit

OK after reinstalling using sage -f r this works for 1. sage -sh 2. sage - R 3. install.packages('orloca'). Thanks for all the help.

mcm3 ( 2012-04-11 20:02:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2012-04-10 19:47:52 -0500

Seen: 515 times

Last updated: Apr 11 '12