Ask Your Question
0

"Type Error" when trying to install a package

asked 2011-01-27 22:19:23 +0200

tdupu10000 gravatar image

updated 2015-01-13 20:54:08 +0200

FrédéricC gravatar image

I'm trying to install the macaulay2 package and I'm getting an error which i can't seem to figure out. Please excuse my newbitude.


sage: install_package(macaulay2)

TypeError Traceback (most recent call last)

/opt/sage-4.6.1-linux-64bit-ubuntu_10.04.1_lts-x86_64-Linux/data/extcode/macaulay2/user/<ipython console=""> in <module>()

/opt/sage-4.6.1-linux-64bit-ubuntu_10.04.1_lts-x86_64-Linux/local/lib/python2.6/site-packages/sage/misc/package.pyc in install_package(package, force) 129 S,O,E = [], [], [] 130 S.extend([P for P in standard_packages()[1] if P.startswith(package)]) --> 131 O.extend([P for P in optional_packages()[1] if P.startswith(package)]) 132 E.extend([P for P in experimental_packages()[1] if P.startswith(package)]) 133 L = S+O+E

TypeError: expected a character buffer object


What does this mean? What do I need to do to fix it?

edit retag flag offensive close merge delete

Comments

hey, try to use code formatting button in the editor - it has numbers written on it, all posts can be edited.

Evgeny gravatar imageEvgeny ( 2011-01-27 22:23:41 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2011-01-27 22:52:30 +0200

tdupu10000 gravatar image

I'm retarded again. The correct input was the string

'macaulay2' rather than just macaulay2 so the correct command is actually install_package('macaulay2')

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-01-27 22:19:23 +0200

Seen: 328 times

Last updated: Jan 27 '11